# Livemesh Addons by Elementor

> Closed on WordPress.org on 2026-04-14 (reason: Security Issue): no more updates from there. Closed for a security issue: replace it.

Source: https://todaywp.com (Today WP, free and read-only). 

## Facts

- Slug: addons-for-elementor
- To check an installed version: wp_security with plugins "addons-for-elementor:<version>".

## Known vulnerabilities

- 2026-04-16 MEDIUM: Missing Authorization to Authenticated (Subscriber+) Stored Cross-Site Scripting via Plugin Settings (up to 9.0). CVE-2026-1572, https://www.wordfence.com/threat-intel/vulnerabilities/id/24b9bf5a-19ac-4e99-b32d-1ab681356a1b?source=api-prod
- 2026-04-16 HIGH: Authenticated (Contributor+) Local File Inclusion via Widget Template Parameter (up to 9.0). CVE-2026-1620, https://www.wordfence.com/threat-intel/vulnerabilities/id/2483875a-84de-4a40-a69e-aee68da1ce3b?source=api-prod
- 2026-02-13 MEDIUM: Authenticated (Contributor+) Stored Cross-Site Scripting (up to 9.0). CVE-2026-39636, https://www.wordfence.com/threat-intel/vulnerabilities/id/ff0e8c96-8401-4d01-8185-03967e2aee54?source=api-prod
- 2024-09-25 MEDIUM: Authenticated (Contributor+) Stored Cross-Site Scripting (up to 8.5). CVE-2024-47303, https://www.wordfence.com/threat-intel/vulnerabilities/id/0119b7c3-0e5b-4448-98fc-662695012532?source=api-prod
- 2024-09-24 MEDIUM: Authenticated (Contributor+) Stored Cross-Site Scripting via piechart_settings Parameter (up to 8.5). CVE-2024-8858, https://www.wordfence.com/threat-intel/vulnerabilities/id/d3c2e5fe-cc02-479e-9f33-e1a783088596?source=api-prod
- 2024-07-06 MEDIUM: Path Traversal (up to 8.4.0). CVE-2024-37547, https://patchstack.com/database/vulnerability/addons-for-elementor/wordpress-elementor-addons-by-livemesh-plugin-8-3-7-local-file-inclusion-vulnerability?_s_id=cve
- 2024-07-03 HIGH: Authenticated (Contributor+) Limited Local File Inclusion via Widgets (up to 8.4). CVE-2024-2385, https://www.wordfence.com/threat-intel/vulnerabilities/id/0aa3ec9b-80d5-4e31-8045-43c8d151cab8?source=api-prod
- 2024-07-03 MEDIUM: Authenticated (Contributor+) Stored Cross-Site Scripting via Marquee Text Widget, Testimonials Widget, and Testimonial Slider Widgets (up to 8.4.1). CVE-2024-3638, https://www.wordfence.com/threat-intel/vulnerabilities/id/58dfd766-7156-4aec-b8db-76908b775ba0?source=api-prod
- 2024-07-03 MEDIUM: Authenticated (Contributor+) Stored Cross-Site Scripting via Various Widgets (up to 8.3.7). CVE-2024-2926, https://www.wordfence.com/threat-intel/vulnerabilities/id/78e9beef-4d2b-4004-8db7-4963882e405b?source=api-prod
- 2024-07-03 MEDIUM: Authenticated (Contributor+) Stored Cross-Site Scripting via Posts Grid (up to 8.3.7). CVE-2024-3639, https://www.wordfence.com/threat-intel/vulnerabilities/id/9729ccc9-e3f1-4096-8430-22998b386cec?source=api-prod
- 2024-04-09 MEDIUM: Authenticated(Contributor+) Stored Cross-Site Scripting via widget _id attribute (up to 8.3.6). CVE-2024-2539, https://www.wordfence.com/threat-intel/vulnerabilities/id/52d79cdd-739f-4ae9-9214-bc64ca7d8ecb?source=api-prod
- 2024-04-09 MEDIUM: Authenticated (Contributor+) Stored Cross-Site Scripting via Display Name (up to 8.3.6). CVE-2024-2655, https://www.wordfence.com/threat-intel/vulnerabilities/id/69f2fc37-4c02-48da-b1e8-350ecc8ba086?source=api-prod
- 2024-03-14 MEDIUM: Cross-site Scripting (up to 8.3.5). CVE-2024-27986, https://patchstack.com/database/vulnerability/addons-for-elementor/wordpress-elementor-addons-by-livemesh-plugin-8-3-5-cross-site-scripting-xss-vulnerability?_s_id=cve
- 2024-03-13 MEDIUM: Authenticated (Contributor+) Stored Cross-Site Scripting via Posts Multislider Widget (up to 8.3.4). CVE-2024-1466, https://www.wordfence.com/threat-intel/vulnerabilities/id/604975b9-fe2f-4d8f-af13-995f08d72e8f?source=api-prod
- 2024-03-13 MEDIUM: Authenticated (Contributor+) Stored Cross-Site Scripting via Posts Slider Widget (up to 8.3.4). CVE-2024-1464, https://www.wordfence.com/threat-intel/vulnerabilities/id/7ce6e40e-b090-447a-9bf9-6337d30e7da3?source=api-prod
- 2024-03-13 MEDIUM: Authenticated (Contributor+) Stored Cross-Site Scripting via Posts Carousel Widget (up to 8.3.4). CVE-2024-1465, https://www.wordfence.com/threat-intel/vulnerabilities/id/96bdd465-e4ca-4a32-b38a-a2a51598a3a9?source=api-prod
- 2024-03-13 MEDIUM: Authenticated (Contributor+) Stored Cross-Site Scripting via Team Members Widget (up to 8.3.4). CVE-2024-1461, https://www.wordfence.com/threat-intel/vulnerabilities/id/d9d37248-d024-4465-a1e6-d8f2d3a2e02f?source=api-prod
- 2024-03-13 MEDIUM: Authenticated (Contributor+) Stored Cross-Site Scripting via Animated Text Widget (up to 8.3.4). CVE-2024-1458, https://www.wordfence.com/threat-intel/vulnerabilities/id/e28b78c3-c370-4076-836e-9f61acba064c?source=api-prod
- 2024-02-12 MEDIUM: Authenticated (Contributor+) Stored Cross-Site Scripting via animated_text_class (up to 8.3). CVE-2024-25598, https://www.wordfence.com/threat-intel/vulnerabilities/id/4397c99c-c37d-43da-9285-003ba91d4003?source=api-prod
- 2024-02-07 MEDIUM: Authenticated (Contributor+) Stored Cross-Site Scripting (up to 8.3.2). CVE-2024-1235, https://www.wordfence.com/threat-intel/vulnerabilities/id/70bda4b7-e442-4956-b3cb-8df96043bcde?source=api-prod
- 2024-01-25 MEDIUM: Authenticated (Contributor+) Stored Cross-Site Scripting (up to 8.3.1). CVE-2024-0448, https://www.wordfence.com/threat-intel/vulnerabilities/id/058d1aa0-2ef6-49a4-b978-43a91c8e55f3?source=api-prod
- 2023-07-18 MEDIUM: Reflected Cross-Site Scripting via fs_request_get (2.0.1 to 7.7.1). WF-5253fe2b-040b-417c-b257-0cb59ee5aa6e-156, https://www.wordfence.com/threat-intel/vulnerabilities/id/5253fe2b-040b-417c-b257-0cb59ee5aa6e?source=api-prod
- 2022-11-21 MEDIUM: Authenticated (Admin+) Stored Cross-Site Scripting (up to 7.2.3). CVE-2022-3862, https://www.wordfence.com/threat-intel/vulnerabilities/id/b1280aec-f253-404e-b03c-d1b8416a6e7d?source=api-prod
- 2022-03-04 MEDIUM: Missing Authorization Checks (before 7.1.4). WF-39fb0499-9ab4-4a2f-b0db-ece86bcf4d42-87, https://www.wordfence.com/threat-intel/vulnerabilities/id/39fb0499-9ab4-4a2f-b0db-ece86bcf4d42?source=api-prod
- 2021-04-13 MEDIUM: Livemesh Addons for Elementor <= 6.7.1- Contributor+ Stored Cross-Site Scripting (up to 6.7.1). CVE-2021-24260, https://www.wordfence.com/threat-intel/vulnerabilities/id/b2340ae3-3b22-4b14-9fce-4b845f2866b1?source=api-prod
- 2019-02-25 HIGH: Missing Authorization to Arbitrary Options Update (before 2.6). WF-3fda31fa-efc9-44b9-99ba-9e3e23aa2ee0-18, https://www.wordfence.com/threat-intel/vulnerabilities/id/3fda31fa-efc9-44b9-99ba-9e3e23aa2ee0?source=api-prod

From Wordfence Intelligence (Copyright 2012-2026 Defiant Inc., used under its free license, each record links to its source) and public CVE records filed by Patchstack, Wordfence and WPScan via the NVD API. This product uses the NVD API but is not endorsed or certified by the NVD.
