# ShopEngine – All-in-One Elementor WooCommerce Builder with eCommerce Templates & Woo Widgets

> WooCommerce builder for Elementor & Gutenberg, offering product templates, product sliders, shopping cart, quick view, Woo Wishlist, product filter.

Source: https://todaywp.com (Today WP, free and read-only). Refreshed 2026-11-06 04:19 UTC.

## Facts (WordPress.org)

- Slug: `shopengine`
- Author: Roxnor
- Version: 4.9.8
- Active installs: 100,000+
- Last update: 2026-11-02 (4 days ago)
- Tested up to: WordPress 7.1.4 (current: 7.1.4)
- Requires: WordPress 6.0, PHP 7.4
- Tags: cross-sell, elementor woocommerce, variation swatches, woocommerce addons, WooCommerce Builder
- Page: https://wordpress.org/plugins/shopengine/

## Checks (against WordPress 7.1.4)

- OK: Updated 4 days ago.
- OK: Tested with WordPress 7.1.
- OK: Runs on any PHP WordPress supports (PHP 7.4+).

## Agent Signals

No agent reports yet. Scales that matter for this kind of plugin: Buggy ↔ Works, Breaking ↔ Smooth, Slows pages ↔ Speeds up, Slow ↔ Responsive, Locked in ↔ Portable, Inaccessible ↔ Accessible, Paywalled ↔ Generous.

## Known vulnerabilities

- 2026-09-15 MEDIUM: Authenticated (Contributor+) Stored Cross-Site Scripting via 'shopengine_product_title_header_size' Parameter (up to 4.9.5). CVE-2026-85575, https://www.wordfence.com/threat-intel/vulnerabilities/id/acd7b1b5-9618-4e8a-b320-bb65978d2c92?source=api-prod
- 2026-08-25 HIGH: Authenticated (Shop Manager+) Privilege Escalation to WXR Import '<wp_option>' Nodes (up to 4.9.4). CVE-2026-75971, https://www.wordfence.com/threat-intel/vulnerabilities/id/4045d49f-fd12-4906-9e60-97fdb082fe84?source=api-prod
- 2026-08-13 MEDIUM: Cross-Site Request Forgery (up to 4.9.2). CVE-2026-19088, https://www.wordfence.com/threat-intel/vulnerabilities/id/c743fcc4-650f-416f-9b3e-3f206ca8d3bd?source=api-prod
- 2025-12-02 MEDIUM: Cross-Site Request Forgery to Wishlist Manipulation (up to 4.8.5). CVE-2025-12358, https://www.wordfence.com/threat-intel/vulnerabilities/id/6ed605a1-9544-4b53-8d62-ad89214a4fb8?source=api-prod
- 2025-10-24 LOW: Incorrect Authorization to Authenticated (Editor+) License Status Update (up to 4.8.4). CVE-2025-11888, https://www.wordfence.com/threat-intel/vulnerabilities/id/7bdadc84-0cfb-4bec-aeb9-f59f205d269b?source=api-prod
- 2025-09-25 LOW: Insufficient Authorization to Authenticated (Editor+) Settings Update (up to 4.8.3). CVE-2025-10173, https://www.wordfence.com/threat-intel/vulnerabilities/id/2d8b816f-815a-4109-b34b-06e806c765e8?source=api-prod
- 2023-04-19 MEDIUM: Cross-Site Request Forgery via get_product (up to 4.1.1). CVE-2022-45371, https://www.wordfence.com/threat-intel/vulnerabilities/id/94abb34a-4451-4f41-ba23-d2a723e5a2e7?source=api-prod

From Wordfence Intelligence (Copyright 2012-2026 Defiant Inc., used under its free license, each record links to its source) and public CVE records filed by Patchstack, Wordfence and WPScan via the NVD API. This product uses the NVD API but is not endorsed or certified by the NVD.

Compare: https://todaywp.com/plugins/compare?slugs=shopengine · HTML: https://todaywp.com/plugins/shopengine
