# Post Grid Blocks & Templates for News, Magazine, & Blog Sites &#8211; PostX

> Closed on WordPress.org on 2026-10-10: no more updates from there.

Source: https://todaywp.com (Today WP, free and read-only). 

## Facts

- Slug: ultimate-post
- To check an installed version: wp_security with plugins "ultimate-post:<version>".

## Known vulnerabilities

- 2026-10-10 HIGH: Unauthenticated Stored Cross-Site Scripting via display_name User Field (up to 5.1.0). CVE-2026-96840, https://www.wordfence.com/threat-intel/vulnerabilities/id/39472e87-174c-4abf-bc83-fed0939440af?source=api-prod
- 2026-09-23 MEDIUM: Unauthenticated Information Exposure (up to 5.0.40). CVE-2026-86783, https://www.wordfence.com/threat-intel/vulnerabilities/id/97919084-d91d-473e-8f9b-d069c4bf22ea?source=api-prod
- 2026-08-06 MEDIUM: Authenticated (Contributor+) Stored Cross-Site Scripting via Post Comments Block (up to 5.0.13). CVE-2026-5158, https://www.wordfence.com/threat-intel/vulnerabilities/id/032861f0-9d94-4f6a-a119-eb0e09b20c5d?source=api-prod
- 2026-07-24 MEDIUM: Authenticated (Contributor+) Stored Cross-Site Scripting via 'searchnoresult' Block Attribute (up to 5.0.32). CVE-2026-15100, https://www.wordfence.com/threat-intel/vulnerabilities/id/1f645d0c-d641-4fff-a4f4-33c037de30e9?source=api-prod
- 2026-07-09 MEDIUM: Authenticated (Contributor+) Stored Cross-Site Scripting via 'moreResultsText' Block Attribute (up to 5.0.31). CVE-2026-13253, https://www.wordfence.com/threat-intel/vulnerabilities/id/070ccd70-22c3-47f1-9dce-a884bff9ea76?source=api-prod
- 2026-04-16 MEDIUM: Missing Authorization to Limited Post Meta Modification (up to 5.0.5). CVE-2026-0718, https://www.wordfence.com/threat-intel/vulnerabilities/id/c4b2cf3b-5d35-4ce6-9453-1538a6f7752f?source=api-prod
- 2026-03-03 HIGH: Authenticated (Administrator+) Server-Side Request Forgery via REST API Endpoints (up to 5.0.8). CVE-2026-1273, https://www.wordfence.com/threat-intel/vulnerabilities/id/afe6d4ac-1712-415e-9995-cb7c8fe4e1a0?source=api-prod
- 2026-01-19 MEDIUM: Missing Authorization (up to 5.0.3). CVE-2025-69313, https://www.wordfence.com/threat-intel/vulnerabilities/id/21b59c8c-671a-45a9-8774-d059c4ad15ba?source=api-prod
- 2025-12-21 MEDIUM: Unauthenticated Information Exposure (up to 5.0.3). CVE-2025-68606, https://www.wordfence.com/threat-intel/vulnerabilities/id/303c8539-7a61-4b9b-81a1-70323c0be7ff?source=api-prod
- 2025-12-20 HIGH: Missing Authorization to Unauthenticated Sensitive Information Exposure (up to 5.0.3). CVE-2025-12980, https://www.wordfence.com/threat-intel/vulnerabilities/id/e85ff3b3-de41-4ac4-b825-b3238725ca44?source=api-prod
- 2025-09-02 MEDIUM: Missing Authorization (up to 4.1.36). CVE-2025-54751, https://www.wordfence.com/threat-intel/vulnerabilities/id/6e031c1d-14c9-4e5d-8881-2f02ee321efe?source=api-prod
- 2025-08-29 HIGH: Authenticated (Editor+) Privilege Escalation (up to 4.1.35). CVE-2025-55707, https://www.wordfence.com/threat-intel/vulnerabilities/id/08ad76c6-8e63-4015-b0d9-5699f24f36ca?source=api-prod
- 2025-03-28 MEDIUM: Authenticated (Contributor+) Stored Cross-Site Scripting (up to 4.1.25). CVE-2025-31096, https://www.wordfence.com/threat-intel/vulnerabilities/id/52a106f6-8d6a-4769-81c0-f8d1bdc72feb?source=api-prod
- 2024-12-02 MEDIUM: Authenticated (Contributor+) Stored Cross-Site Scripting (up to 4.1.15). CVE-2024-53818, https://www.wordfence.com/threat-intel/vulnerabilities/id/af55ea6c-01f6-4c87-91bb-a0ff98e92256?source=api-prod
- 2024-11-15 HIGH: Missing Authorization to Arbitrary Plugin Installation/Activation (up to 4.1.16). CVE-2024-10728, https://www.wordfence.com/threat-intel/vulnerabilities/id/076f36fb-c2fb-43e0-a027-1351d3995489?source=api-prod
- 2024-10-28 MEDIUM: Authenticated (Author+) Stored Cross-Site Scripting (up to 4.1.15). CVE-2024-50513, https://www.wordfence.com/threat-intel/vulnerabilities/id/97df0ac7-3240-4d2b-aa2c-779c8e9359e8?source=api-prod
- 2024-10-24 MEDIUM: Authenticated (Contributor+) Stored Cross-Site Scripting (up to 4.1.12). CVE-2024-50443, https://www.wordfence.com/threat-intel/vulnerabilities/id/f9eb02f4-ad47-41f2-b3a7-e3f73d7a1bc3?source=api-prod
- 2024-05-29 HIGH: Missing Authorization to Arbitrary Options Update (up to 4.1.2). CVE-2024-5326, https://www.wordfence.com/threat-intel/vulnerabilities/id/07a3db33-3787-4b63-835d-8e3026206842?source=api-prod
- 2024-05-29 MEDIUM: Authenticated (Author+) Stored Cross-Site Scripting (up to 4.1.1). CVE-2024-5223, https://www.wordfence.com/threat-intel/vulnerabilities/id/7234d4b9-a575-428a-9d08-2dc62ba41c30?source=api-prod
- 2024-05-27 MEDIUM: Authenticated (Contributor+) Stored Cross=Site Scripting (up to 4.0.4). CVE-2024-4305, https://www.wordfence.com/threat-intel/vulnerabilities/id/4dcc3f47-8504-4aa6-af60-03edeaa39fd7?source=api-prod
- 2024-04-22 MEDIUM: Authenticated (Contributor+) Stored Cross-Site Scripting (up to 4.0.1). CVE-2024-3239, https://www.wordfence.com/threat-intel/vulnerabilities/id/482bf861-e556-40af-b522-c22ef6c9938b?source=api-prod
- 2024-04-16 MEDIUM: Authenticated (Contributor+) Stored Cross-Site Scripting (up to 4.0.1). CVE-2024-32564, https://www.wordfence.com/threat-intel/vulnerabilities/id/cce4d44a-4613-4230-ace1-2d26c7c487b3?source=api-prod
- 2024-04-05 MEDIUM: Incorrect Authorization (up to 3.2.3). CVE-2024-31246, https://www.wordfence.com/threat-intel/vulnerabilities/id/c2fd1bd8-dcc2-4c9a-be3f-b0a58992a239?source=api-prod
- 2023-08-02 MEDIUM: Gutenberg Post Grid Blocks <= 3.0.5 - Reflected Cross-Site Scripting via 'postx_type' (up to 3.0.5). CVE-2023-3992, https://www.wordfence.com/threat-intel/vulnerabilities/id/5ab2e2ae-6f46-4815-a2d2-407767bfaba8?source=api-prod
- 2023-06-23 HIGH: Unauthenticated Cross-Site Scripting (up to 2.9.9). CVE-2023-36385, https://www.wordfence.com/threat-intel/vulnerabilities/id/d0c9f4c5-a4f6-4cab-8531-5b88b3f347ea?source=api-prod
- 2021-08-26 MEDIUM: Gutenberg Blocks for Post Grid <= 2.4.9 - Authenticated (Contributor+) Stored Cross-Site Scripting (before 2.4.10). CVE-2021-24659, https://www.wordfence.com/threat-intel/vulnerabilities/id/52b1d515-4965-4ab9-80dd-526b4ebeb3a9?source=api-prod
- 2021-08-26 MEDIUM: Gutenberg Blocks for Post Grid <= 2.4.9 - Stored Cross-Site Scripting (before 2.4.10). CVE-2021-24660, https://www.wordfence.com/threat-intel/vulnerabilities/id/7b6ac72f-11f4-46bd-a972-fbcb46b34ce6?source=api-prod
- 2021-08-26 MEDIUM: Private Content Disclosure (up to 2.4.9). CVE-2021-24661, https://www.wordfence.com/threat-intel/vulnerabilities/id/830a8e85-6134-4f85-996f-b0cb7ccb9d5c?source=api-prod
- 2021-08-17 MEDIUM: Gutenberg Blocks for Post Grid <= 2.4.9 - Unauthorized Access Controls (before 2.4.10). CVE-2021-24652, https://www.wordfence.com/threat-intel/vulnerabilities/id/b323d910-23f6-41e2-9d64-d60398994996?source=api-prod

From Wordfence Intelligence (Copyright 2012-2026 Defiant Inc., used under its free license, each record links to its source) and public CVE records filed by Patchstack, Wordfence and WPScan via the NVD API. This product uses the NVD API but is not endorsed or certified by the NVD.
