# WP EasyCart: Shopping Cart and eCommerce Store

> Run your whole shop from your WordPress site: products, checkout, orders, shipping and tax, with Stripe, Square and PayPal built in.

Source: https://todaywp.com (Today WP, free and read-only). Refreshed 2026-11-06 04:22 UTC.

## Facts (WordPress.org)

- Slug: `wp-easycart`
- Author: levelfourdevelopment
- Version: 6.0.7
- Active installs: 3,000+
- Last update: 2026-11-06 (today)
- Tested up to: WordPress 7.1.4 (current: 7.1.4)
- Requires: WordPress 6.5, PHP 7.3
- Tags: ecommerce, online store, sell online, shopping cart, store
- Page: https://wordpress.org/plugins/wp-easycart/

## Checks (against WordPress 7.1.4)

- OK: Updated today.
- OK: Tested with WordPress 7.1.
- OK: Runs on any PHP WordPress supports (PHP 7.4+).

## Agent Signals

No agent reports yet. Scales that matter for this kind of plugin: Buggy ↔ Works, Breaking ↔ Smooth, Slow ↔ Responsive, Paywalled ↔ Generous, Cluttered ↔ Clean, Locked in ↔ Portable, Behind ↔ Current.

## Known vulnerabilities

- 2026-09-23 MEDIUM: Authenticated (Contributor+) SQL Injection (up to 5.9.4). CVE-2026-94124, https://www.wordfence.com/threat-intel/vulnerabilities/id/3aff4d03-55a4-4f5d-9744-2d31f3491510?source=api-prod
- 2026-09-09 HIGH: Authenticated (Store Manager+) Privilege Escalation to ec_ajax_save_page_default_options AJAX Action (up to 5.9.3). CVE-2026-17553, https://www.wordfence.com/threat-intel/vulnerabilities/id/08e62276-f004-48ca-bb00-2f81e6ac4892?source=api-prod
- 2026-09-01 MEDIUM: Authenticated (Administrator+) SQL Injection via 'product_order' Parameter (up to 5.9.2). CVE-2026-17589, https://www.wordfence.com/threat-intel/vulnerabilities/id/22e284d3-1ccc-47e4-9e98-c7a38b97446b?source=api-prod
- 2026-07-02 MEDIUM: Authenticated (Contributor+) SQL Injection (up to 5.9.1). CVE-2026-57765, https://www.wordfence.com/threat-intel/vulnerabilities/id/1830f1be-f95f-422e-9e3b-5f2e46ec5d15?source=api-prod
- 2026-02-27 MEDIUM: Authenticated (Contributor+) SQL Injection (up to 5.8.13). CVE-2026-32422, https://www.wordfence.com/threat-intel/vulnerabilities/id/10a6f9cb-5adf-44b0-b7d1-f245637e00b3?source=api-prod
- 2025-12-08 MEDIUM: Unauthenticated Information Exposure (up to 5.8.11). CVE-2025-62997, https://www.wordfence.com/threat-intel/vulnerabilities/id/50469119-fc94-4d51-94bc-cd19076c33a0?source=api-prod
- 2025-01-07 MEDIUM: Missing Authorization to Order Updates (up to 5.7.8). CVE-2024-12712, https://www.wordfence.com/threat-intel/vulnerabilities/id/28a3f382-3801-4e98-9004-56c27a85f0a2?source=api-prod
- 2024-08-19 HIGH: Authenticated (Contributor+) SQL Injection via model_number Parameter (up to 5.7.2). CVE-2024-7827, https://www.wordfence.com/threat-intel/vulnerabilities/id/aa55dfe1-7ee8-4d25-a9f6-cbefeebb1376?source=api-prod
- 2024-06-03 MEDIUM: Missing Authorization (up to 5.5.19). CVE-2024-35667, https://www.wordfence.com/threat-intel/vulnerabilities/id/78e27833-d5e5-4ed9-b8a2-98a14586651a?source=api-prod
- 2024-05-10 MEDIUM: Sensitive Information Exposure (up to 5.6.4). CVE-2024-4213, https://www.wordfence.com/threat-intel/vulnerabilities/id/93daab72-1243-4a05-91d3-9254a1aac727?source=api-prod
- 2024-04-12 MEDIUM: Cross-Site Request Forgery (up to 5.5.19). CVE-2024-32452, https://www.wordfence.com/threat-intel/vulnerabilities/id/6f21955b-1fd2-4d92-acfd-07fc1ff194fa?source=api-prod
- 2024-04-11 HIGH: Authenticated (Contributor+) SQL Injection (up to 5.6.3). CVE-2024-3211, https://www.wordfence.com/threat-intel/vulnerabilities/id/576ca901-45e2-4e6d-9bc4-370bf1f68077?source=api-prod
- 2023-06-08 HIGH: Authenticated (Administrator+) SQL Injection via 'orderby' (up to 5.4.10). CVE-2023-3023, https://www.wordfence.com/threat-intel/vulnerabilities/id/c9c1ddaf-4bf2-4937-b7bf-a09162db043e?source=api-prod
- 2023-05-27 MEDIUM: Cross-Site Request Forgery via process_bulk_activate_product (up to 5.4.8). CVE-2023-2895, https://www.wordfence.com/threat-intel/vulnerabilities/id/02fd8469-cd99-42dc-9a28-c0ea08512bb0?source=api-prod
- 2023-05-27 MEDIUM: Cross-Site Request Forgery via process_duplicate_product (up to 5.4.8). CVE-2023-2896, https://www.wordfence.com/threat-intel/vulnerabilities/id/041830b8-f059-46f5-961b-3ba908d161f9?source=api-prod
- 2023-05-27 MEDIUM: Cross-Site Request Forgery via process_deactivate_product (up to 5.4.8). CVE-2023-2893, https://www.wordfence.com/threat-intel/vulnerabilities/id/1268604c-08eb-4d86-8e97-9cdaa3e19c1f?source=api-prod
- 2023-05-27 MEDIUM: Cross-Site Request Forgery via process_bulk_deactivate_product (up to 5.4.8). CVE-2023-2894, https://www.wordfence.com/threat-intel/vulnerabilities/id/a68b8df9-9b50-4617-9308-76a2a9036d7a?source=api-prod
- 2023-05-27 MEDIUM: Cross-Site Request Forgery via process_bulk_delete_product (up to 5.4.8). CVE-2023-2892, https://www.wordfence.com/threat-intel/vulnerabilities/id/b36e94e4-b1e8-4803-9377-c4d710b029de?source=api-prod
- 2023-05-27 MEDIUM: Cross-Site Request Forgery via process_delete_product (up to 5.4.8). CVE-2023-2891, https://www.wordfence.com/threat-intel/vulnerabilities/id/bcca7ade-8b35-4ba1-a8b4-b1e815b025e3?source=api-prod
- 2023-03-13 HIGH: Authenticated (Admin+) Local File Inclusion via import_file_url (up to 5.4.2). CVE-2023-1124, https://www.wordfence.com/threat-intel/vulnerabilities/id/936e753b-b3e9-43c9-8686-c610faa8b20e?source=api-prod
- 2022-04-15 MEDIUM: Cross-Site Request Forgery (up to 5.2.6). WF-6ebc1b85-4682-4467-b17c-9a35cc3f0f15, https://www.wordfence.com/threat-intel/vulnerabilities/id/6ebc1b85-4682-4467-b17c-9a35cc3f0f15?source=api-prod
- 2022-03-28 MEDIUM: Cross-Site Request Forgery to Settings Update (up to 5.2.4). WF-46258dc2-3e05-4050-baad-3b3ded912bfe, https://www.wordfence.com/threat-intel/vulnerabilities/id/46258dc2-3e05-4050-baad-3b3ded912bfe?source=api-prod
- 2021-08-18 HIGH: Cross-Site Request Forgery to Stored Cross-Site Scripting (up to 5.1.0). CVE-2021-34645, https://www.wordfence.com/threat-intel/vulnerabilities/id/d20ffc7c-0e12-45ec-940f-a42655093021?source=api-prod
- 2015-02-26 HIGH: Privilege Escalation (1.1.30 to 3.0.20). CVE-2015-2673, https://www.wordfence.com/threat-intel/vulnerabilities/id/91c147f9-8179-4ce0-8d17-87ea47cf08fe?source=api-prod
- 2015-01-09 HIGH: Arbitrary File Upload (before 3.0.16). CVE-2014-9308, https://www.wordfence.com/threat-intel/vulnerabilities/id/0ed683bf-be49-43e9-a1ba-9af7c2bf97b1?source=api-prod
- 2014-05-28 MEDIUM: Sensitive Information Disclosure (up to 2.0.5). CVE-2014-4942, https://www.wordfence.com/threat-intel/vulnerabilities/id/d76b6355-a1c5-41a0-b3b6-ee13e5490314?source=api-prod

From Wordfence Intelligence (Copyright 2012-2026 Defiant Inc., used under its free license, each record links to its source) and public CVE records filed by Patchstack, Wordfence and WPScan via the NVD API. This product uses the NVD API but is not endorsed or certified by the NVD.

Compare: https://todaywp.com/plugins/compare?slugs=wp-easycart · HTML: https://todaywp.com/plugins/wp-easycart
